Recent content by JoeSpit

  1. JoeSpit

    Sputtering and stalling only while driving

    nice hatch! i'm either gonna make my own or use one of those hatch doors for boats
  2. JoeSpit

    Sputtering and stalling only while driving

    I'd recommend a dremel tool with cut off wheel. i did a total tank clean out when i put in pump 3. I was thinking bad gas or maybe more ethenol that advertised maybe eating away at the solder contacts or something? but i dunno, got my hatch now so i can change it out in minutes now 🙃
  3. JoeSpit

    Sputtering and stalling only while driving

    That was a Napa branded one. Napa would not give me a 4th pump so they refunded me full and I bought a “precision” one from o’rielys The Napa one had a wire break off at the solder point within the assembly. I forgot to snap a pic I ended up cutting a hole in the rear floor pan (and a lil of...
  4. JoeSpit

    Sputtering and stalling only while driving

    Is there something that can short out a pump (or 3)? Maybe this says that the Safeway has poor fuel quality? Hence it being cheapest?
  5. JoeSpit

    Sputtering and stalling only while driving

    Aaaaand my now 3rd replacement pump is dead and I’m waiting for aaa …again. This time it’s not even sputtering it’s just dead. I was driving and it just cut out. Of course I had filled it up last night so now I’ll have to removed the tank full weight 😩
  6. JoeSpit

    Sputtering and stalling only while driving

    welp sure enough i should have trusted my 1st instinct... it WAS a second bad fuel pump. Now for better or for worse, i couldnt get a third delphi as it seems i used all of napas hawaii supply of them. So i have a NAPA branded one, which already the fuel level sending unit didnt work from the...
  7. JoeSpit

    Sputtering and stalling only while driving

    yeah im gonna check to see if my jb weld remedies in the am. if that aint it, i know its the fuel pump. Good thing is i'll probably be able to switch in like 40 minutes i've done it soo often and recently lol but one forum post was getting similar issues because of cracked exhaust. so i'm...
  8. JoeSpit

    Sputtering and stalling only while driving

    okay the PCM is fine, i was either reading the wrong pin or my back probe wasnt inserted all the way. I did however notice another small crack on my exhaust near the engine mount. It's in such a cramped spot I'm not sure if i can JB weld it. So now do i bother rere-replacing the pump i...
  9. JoeSpit

    Sputtering and stalling only while driving

    i did and nothing different 🙃 however i'm leaning towards (another) bad pump. But i figured i would also check my PCM to make sure thats not fried and i get proper reading on all the important pins buts pin 2 which says it's "fused ignition switch output" supposedly i'm to get a 12v reading...
  10. JoeSpit

    97 TJ sputtering and losing power

    It looks like my pin 2 and 22 (fuse B+ and Ignition) dont have proper voltage. My jeep starts but after it comes to temp it will sputter and stall. what do i need to check?
  11. JoeSpit

    97 TJ sputtering and losing power

    today i high heat JB welded the crack and it still sputters to a stall. i am completely drained and out of ideas from this fucking gremlin. i have another exhaust manifold on the way but i really dont feel like installing it if its ot going to fix anything i guess ill try another fuel pump...
  12. JoeSpit

    97 TJ sputtering and losing power

    i figured it out... Cracked exhaust man 🙃
  13. JoeSpit

    Sputtering and stalling only while driving

    so looking deep into the forums archives someone had a similar issue because of a cracked exhaust then i noticed this...crack in my exhaust... i didnt notice my exhaust being any louder but i would get a whistleing i thought was vacuum. Probably this? which would make more sense than 2 faulty...
  14. JoeSpit

    Another Sputtering ,stuttering , stalling TJ

    you mean like this? that would explain everything considering i have changed out just about every sensor an looked over all the wiring and was getting ready to look up my insurance policies fire coverage lol
  15. JoeSpit

    Sputtering and stalling only while driving

    just switched out crank sensor and no difference. Aside from cam sensor, i have basically changed out everything and i'm back to thinking its a faulty fuel pump. So tomorrow ill pull and swap out for another one. That was my original problem so maybe its just that. After all it was running like...