• Want to add an app icon for this forum to your mobile device's home screen? Check out this thread to see how.
  • Have an event you want to share? Check out the new forum event calendar and how-to use it in this thread here.
  • To both new members and existing members, please read this thread about posting your topics in the correct sub-forum. It makes my job (and my life) a lot easier!

Search results

  1. M

    Stereo makes loud crack and turns off and engine cuts off shortly after being started

    @Jerry Bransford Thanks! Yeah I'm definitely not an electronics experts by any stretch. Good point, yeah there was no smoking/burning smells or anything like that. The main battery ground (I think?) connected to a big bolt in the firewall... I took off and cleaned up with the dremel wire...
  2. M

    Stereo makes loud crack and turns off and engine cuts off shortly after being started

    @PatMc I'll give that a try. It'll also give me a chance to check the condition of the ground there. Wasn't sure if that would cause the issue or not, but if the other bolts are any indication it might have some rust on it. @Goatman @Chris How would I go about troubleshooting that? I have an...
  3. M

    Stereo makes loud crack and turns off and engine cuts off shortly after being started

    So just happened again tonight. Drove to Lowe's and came back out. Put the key in the ignition and it cranked for a second before all if the electrical systems went dead. After a few seconds the cluster light came back on, the clock was reset. Started up and drive home just fine after. I figure...
  4. M

    Battery Replacement

    I had a due hard platinum for years, but there weren't any Sears still open close by when I replaced it a few years back. That was a great battery. Now I just have a Duralast gold in there. Don't have any complaints with it.
  5. M

    05-06 PCM issue is solved

    Consider me another satisfied customer! I have a 2006 auto TJ. I've had a P1604 since last year, also had the hard shift issue and decided to pull the trigger on this one after reading a few reports. Mark has excellent customer service, called my cell the night I put the order in. PCM came a...
  6. M

    Stereo makes loud crack and turns off and engine cuts off shortly after being started

    2006 TJ, 4l auto So I had 2 electrical issues come up twice so far. Both times were independent of each other, and happened at random. The only thing I'd noticed that was it was on 2 of the warmer days we've had this fall. I'd recently replaced my dying PCM, and I'd read some similar issues...
  7. M

    Is this a bad OPDA?

    @bromel Thank you much! It's an 06. Yeah I'd watched a few of the odpa videos and it sounded pretty similar (but not quite the same). I'm ordering the crown unit now. I'm seeing in the reviews there to just reuse the existing sensor.
  8. M

    Is this a bad OPDA?

    Started hearing this noise yesterday. I had just come home from some highway driving, and was ready to go out for the evening. Noticed this over the radio. I haven't driven it since, except to pull it down the driveway. Sounds to me like the OPDA squeel, but not so sure. I think it sounds more...
  9. M

    Flare bolt stuck in nutsert

    @mrblaine Thanks! Is the approach I'm wanting to take pretty much the only option I have at this point (considering I'm not trying to ruin my flare)? I think even if I got a right angle drill head for my oscillating tool, it would probably be too tight to drill that out. Once I cut that off...
  10. M

    Flare bolt stuck in nutsert

    So I was trying to tackle some minor body work right in front of my rear flare. I'd replaced the front fender last year with no problems at all. On this one though, every nutsert I've come across has just been spinning. I can't get my dremel cut off wheel up in there because the flare is still...