05 Sport build (Mid Life Crisis)

OP
DougyintheBushies

DougyintheBushies

TJ Enthusiast
Joined
Nov 15, 2021
Messages
567
Location
Chickamauga, Ga
I got some fluids and gasket maker.

1FAC6A1F-1EA6-4A7E-A7B1-B1DB324BEF6C.png


C59490E2-CD62-4CCA-AD3B-6D95FB8E59E0.png


560017C2-3CF4-4D28-B477-A880540D0D32.png
 
OP
DougyintheBushies

DougyintheBushies

TJ Enthusiast
Joined
Nov 15, 2021
Messages
567
Location
Chickamauga, Ga
I got to work on the Jeep allitle today. Adjusted the front and got some caster back. I measured the ball joint angle with my iPhone rigid app. It read 5* caster and that put the DS roughly 1-2 * above the pinion.
I then took off the front diff cover and cleaned it up.

15748F9D-87FD-4351-9181-00BD27C7958B.jpeg


ED431284-2E72-480C-80A6-4022E1F7FAE0.jpeg


6B57C39A-D8EE-412B-873D-37D9A15F20BE.jpeg


365467CA-F2A9-4018-98DB-5303C8796A22.jpeg
The po had a dropped pitman arm and bracket that was wacking the cover. I choose to grind down that fin to make it look better. I still haven’t took the coils out to set up clearance and bumpstops.
 
  • Like
Reactions: Wildman
OP
DougyintheBushies

DougyintheBushies

TJ Enthusiast
Joined
Nov 15, 2021
Messages
567
Location
Chickamauga, Ga
I’m still getting vibes under hard load and I’m pretty sure it’s the rear DS.
I bought a digital angle finder to get a little more accurate on the pinion angle. I have been using my I phone.

98FD8741-E997-4CF6-B7E2-C95523EAB263.png

Next up I’m going to order new u joints and centering ball for the dc driveshaft if I can figure out which one to order
 
OP
DougyintheBushies

DougyintheBushies

TJ Enthusiast
Joined
Nov 15, 2021
Messages
567
Location
Chickamauga, Ga
I ordered (3) 5-1310x u joint to rebuild the rear drive shaft. These vibes are driving me crazy.🤬 I hope this fixes them. I’m thinking after changing the pinion angle the old joints were worn so they aren’t used to the change. I can tap the drive shaft and get a small clunk sound.

195B1674-337F-4F05-B6CB-909B43E78F3B.png
 
OP
DougyintheBushies

DougyintheBushies

TJ Enthusiast
Joined
Nov 15, 2021
Messages
567
Location
Chickamauga, Ga
I went to rebuild my rear dc drive shaft and ran into a problem. The rear is a greaseable one and I had a spair non greaseable centering ball yoke for the front.I ordered one from Amazon but it won’t be here till Tuesday.

329D2814-9506-49CF-83CD-CDFA4C22E445.jpeg


E32BF3C6-28E0-4932-B226-3575D91A7699.png


89EF169C-B4F4-4ADF-B585-B2ABFFD5DF0B.jpeg
 

LONGJP2

TJ Expert
Joined
Aug 11, 2019
Messages
3,136
Location
Illinois
Read through your build.
Very impressed with the amount of work in a short time.
Only one thing.
I can't believe you were able to remove your pitman arm using PB Blaster. :D
 
  • Like
Reactions: DougyintheBushies
OP
DougyintheBushies

DougyintheBushies

TJ Enthusiast
Joined
Nov 15, 2021
Messages
567
Location
Chickamauga, Ga
Read through your build.
Very impressed with the amount of work in a short time.
Only one thing.
I can't believe you were able to remove your pitman arm using PB Blaster. :D

Thanks I think I got a problem😁Pb blaster seams to work pretty good for me, but I’m not seeing a bunch of rusty bolts either.
 
OP
DougyintheBushies

DougyintheBushies

TJ Enthusiast
Joined
Nov 15, 2021
Messages
567
Location
Chickamauga, Ga
Drove the Jeep to work this morning and finally I'm confident to say the vibes are gone and drives smooth now. Driving with the bad DC joint did cause my pinion seal to leak, so I need to address that.
Next will be a battery and figure out the darty steering,
 
OP
DougyintheBushies

DougyintheBushies

TJ Enthusiast
Joined
Nov 15, 2021
Messages
567
Location
Chickamauga, Ga
I’ m still getting a knocking noise under load. So I checked the u joint I just put in and it’s loose still. I have a spare axle and new u joint I can swap in cause I’m not sure why it would have play still.

89CD454B-D120-4A7A-B11A-7F34E1F23D38.jpeg
 
OP
DougyintheBushies

DougyintheBushies

TJ Enthusiast
Joined
Nov 15, 2021
Messages
567
Location
Chickamauga, Ga
Must have been a stretched stub shaft. Swapped in a spare stub and reused the u-joint and no play now. I’m still getting a popping sound under load.
I guess it’s this lunchbox locker.
I need to swap out the driver u-joint .