05 TJ won’t start when hot


Jeepster05

New Member
Joined
Feb 22, 2021
Messages
5
Location
Florida
So I have owned my Jeep TJ for about two 1/2 years now. When I brought my Jeep the guy had told me about a over heating problem the Jeep has had. He had changed the radiator to a aluminum radiator, changed the Fan blade and the fan clutch. The fan blade he installed was a plastic fan blade from another car. I had to replace the cooling temperature sensor and that sloved the over heating issue. I have also change/ replace the radiator, fan blade and clutch back to original. But here is my problem now. So if I driving the jeep around on a hot day and I enter a store for 10 to 15 minutes come back out and try to start the jeep up. It will not want to start. The Jeep will crank but will not start up. I will have to wait like about 20 minutes and the jeep will start up. Funny thing is that this doesn't happened all the time. I've even covered the fuel rail thinking about the heat from the engine causing a vapor gas lock do to the amount of heat. Has anyone ever experienced this issue with there Jeep TJ????
 

TWiG01

TJ Enthusiast
Supporting Member
Joined
Jun 1, 2020
Messages
904
Location
New Jersey
Sounds like a heat soak issue. Check this thread out, there is some good info in the links

 

Chris

Administrator
Staff Member
Ride of the Month Winner
Joined
Sep 28, 2015
Messages
60,872
Location
Florence, AZ
Sounds like heat soak or a potentially bad drain back valve in the fuel pump assembly. That can be ruled out by priming the fuel pump multiple times before starting.
 
OP
Jeepster05

Jeepster05

New Member
Joined
Feb 22, 2021
Messages
5
Location
Florida
Sounds like a heat soak issue. Check this thread out, there is some good info in the links

I will have to agree with you about the heat soak. I removed the cats of the Jeep and wow what a big difference in the way the Jeep runs. Now I had the same problem before I removed the cats . I was told most of the heat comes from the cats. Now I have rap the fuel rail and the injectors with a heat shield product. But that has not help me issue. Funny thing is that this issue is intermittent. Last time this happend its been two weeks ago. I purchased some hood vents which I will be installing soon to help with some more heat extraction.
 
OP
Jeepster05

Jeepster05

New Member
Joined
Feb 22, 2021
Messages
5
Location
Florida
No I have not check the starter because the jeep starts up find. When is doesn't want to start it acts like it's not getting Gas at that moment. I have a brand new Red top optima battery so it can not be that.
 

WallyWest

TJ Addict
Joined
Nov 6, 2019
Messages
1,267
Location
PA
Fuel pump.

Drive it around for a bit to get it hot, take it to a mechanic, have them check fuel pressure when trying to start it hot.

Had the same exact symptoms and that's what it was. Crank but no start when hot, let it cool down and it would fire right up.
 
OP
Jeepster05

Jeepster05

New Member
Joined
Feb 22, 2021
Messages
5
Location
Florida
Fuel pump.

Drive it around for a bit to get it hot, take it to a mechanic, have them check fuel pressure when trying to start it hot.

Had the same exact symptoms and that's what it was. Crank but no start when hot, let it cool down and it would fire right up.
This is driving me crazy cause it doesn't happens all the time. The last time it happend. It's been like three weeks ago and it has not done it. Weve had some nice weather here . Yea and when this happens on the first crank I have to wait for like 20 minutes or so. Then when I try to crank the jeep up and it does start up its jumpy shaking I give it gas and it's fine . It will drive perfect. I just can't figure it out. I know what's going to happen. I will take it to a mechanic and they going to tell.me they can not fine any problem with the jeep. Cause it will not do it with them. LOL
 

tr21triton

TJ Enthusiast
Joined
Dec 13, 2020
Messages
295
Location
Blue Ridge' Ga
i bought 97 in December and when i opened the hood saw wooden clothes pins clamped on the fuel line. asked the seller about it and he said he had a vapor lock and put the pins on it with no more problem , huh ! never heard of such, but ok. i'll get pics today maybe you can try it, what maybe a dollar worth of pins it's worth a try...
 

WallyWest

TJ Addict
Joined
Nov 6, 2019
Messages
1,267
Location
PA
This is driving me crazy cause it doesn't happens all the time. The last time it happend. It's been like three weeks ago and it has not done it. Weve had some nice weather here . Yea and when this happens on the first crank I have to wait for like 20 minutes or so. Then when I try to crank the jeep up and it does start up its jumpy shaking I give it gas and it's fine . It will drive perfect. I just can't figure it out. I know what's going to happen. I will take it to a mechanic and they going to tell.me they can not fine any problem with the jeep. Cause it will not do it with them. LOL

Exactly how mine behaved. It was pretty random at first but got to the point where I it happened every time it was hot. That took probably a year or so to get there though.

I didn't see how it could be the fuel pump since it seemed to be related to engine temp, but my mechanic was positive that was the problem and once he put a new pump in it never did it again.

Not saying that's 100% your issue, but worth checking out. In general it's either not getting fuel, spark, or air. Or battery/starter issues, but as long as it cranks good you can likely rule that out.