• Want to add an app icon for this forum to your mobile device's home screen? Check out this thread to see how.
  • Have an event you want to share? Check out the new forum event calendar and how-to use it in this thread here.
  • To both new members and existing members, please read this thread about posting your topics in the correct sub-forum. It makes my job (and my life) a lot easier!

2006 TJ no front parking lights

EMSQUID

New Member
Joined
Nov 2, 2017
Messages
4
Location
Upstate NY, United States
Out of the blue my front parking lights stop working, all other function of the lights work, ( it’s just the parking lights ), including the side marker light. All fuses are good, bulbs are good, what could possibly be the issue?
 

Steel City 06

TJ Addict
Joined
Mar 12, 2019
Messages
1,343
Location
Pittsburgh, PA
Have you checked the ground wire for those lights? The way the lights are set up is not the simplest. The sidemarker lights ground through the filaments of the front lights.
Perhaps a new flasher relay?
 
  • Like
Reactions: EMSQUID
OP
EMSQUID

EMSQUID

New Member
Joined
Nov 2, 2017
Messages
4
Location
Upstate NY, United States
Have you checked the ground wire for those lights? The way the lights are set up is not the simplest. The sidemarker lights ground through the filaments of the front lights.
Perhaps a new flasher relay?
Thanks for the info, tried the relay, that wasn’t the problem. Finally took on the chore of unwrapping all the wires from the sockets back. Found that someone before me spliced into the power wire for the marker lights with a snap type connector. The wires were corroded and broken on both left and right parking lights. Repaired the cuts, mended the wires, we’re good to go. Now I have to figure out what’s wrong with the headlights, stay tune for my next question, lol! Thanks!
 
  • Like
Reactions: Steel City 06