32RH revived


Turdworlder

Member
Joined
Mar 2, 2020
Messages
65
Location
Kazakhstan
I dont know what happened, i didnt open it, didnt use any magic atf or lucas oil. After seating for 1 day without accumulator the transmission somehow revived, before it used to hesitate, whine, high rev. Now it all gone.
My question is why and how it happened? I previously wrote here with complains about 32rh, the dash obd doesnt show any error with 3x times key play, check engine turns off after engine is cranked but when cluster is on it shows chexk engine.
 
OP
Turdworlder

Turdworlder

Member
Joined
Mar 2, 2020
Messages
65
Location
Kazakhstan
Also after advices from here, i thoroughly napkin checked all leakings and atf probe, it has no black clutch matter or any signs of burnt, in fact the new atf in bottle has more worser smell, it smell like outdated rotten matter.
 

Jerry Bransford

TJ Guru Moderator
Staff Member
Supporting Member
Joined
Nov 9, 2015
Messages
15,891
Location
Escondido California
Did you replace the ATF with more ATF+4? Did you add more ATF+4? The 32RH itself is not connected to the computer so it won't generate any Check Engine codes, though its lock-up torque converter can cause a code to be generated if it doesn't engage. The code just says the computer didn't see the expected 150 or so engine rpm drop after it signaled to lock-up on the torque converter to engage.
 
OP
Turdworlder

Turdworlder

Member
Joined
Mar 2, 2020
Messages
65
Location
Kazakhstan
Did you replace the ATF with more ATF+4? Did you add more ATF+4? The 32RH itself is not connected to the computer so it won't generate any Check Engine codes, though its lock-up torque converter can cause a code to be generated if it doesn't engage. The code just says the computer didn't see the expected 150 or so engine rpm drop after it signaled to lock-up on the torque converter to engage.
I added 250 mgs of atf+4 but the probe is very tricky on neutral the oil is all over the probe almost to the end where plastic ring is, so i leaked some oil from radiator hose, but it didnt help. Overall after hybernation without battery the car acting very strange. The temperature goes to 210f first time i ever owned the jeep, the heater core blows very hot air almost like sauna.