ASD relay clicking

English Guy 1

New Member
Apr 17, 2018
4
England, UK
Good morning from England one and all,just joined this Jeep TJ Wrangler forum so my first post on the site.Have filled in the info on my 1997 4.0 TJ RHD 4" 86.000 miles 4" lift pretty standard really.Recently over the last month i have been experiencing a intermittent problem with engine stumbling during driving.When this occurs i have stopped the jeep and looked for the source of the problem.My findings are that when this engine stumbling occurs,i can hear the ASD clicking on and off in the PDC fuse/relay box in the engine bay.So my first though was bad relay,so immediately swapped the ASD for the horn relay as same part number item.The result was no change same problem occurred.So consulted the 1997 TJ Jeep service manual fuel system 14-31 diagnosis and testing fig 24 ASD and fuel pump relay terminals.Followed the procedure on all three of my relays ASD fuel pump and horn.All passed the test with 72.2 ohms 71.3 ohms and 73.1 ohms default is 75 + or - 5 ohms.Continuity pass and non continuity etc all pass testing as per specification.So no problem there,I read the service manual ref correct function of the ASD /fuel pump relay operation, with key in on position but engine not running. I have found a fault here also,sometimes when i turn ignition key to on position i hear the in tank 19 gallon fuel pump run constantly this is wrong .As stated by the service manual this should not happen.It is designed to run approx 3 seconds then the PCM shuts it down via the ASD relay by opening the earth connection due to the engine not running as no crank signal to PCM .Most of the time i do get fuel pump running just for the three second prime function in the ignition key on position.So i appear to have a fault in the ASD/FUEL PUMP circuit.My instinct was to immediately check all of my ground points for the PCM which i found to be located at the back r/h side of the engine block two black and tan wires colour code.In fact i went to town on all the engine /frame ignition coil earth points in the engine bay firewall etc.Cleaned them all up to good clean contact surface finish and reattached securely. Even did an ohms test on the PCM black connector earth pins 31 and 32 which go to the ground point at rear r/d side of engine block two black/tan wires found to be 4.5 ohms i think this is too high i would have expected approx 0.025 ohms based on approx length 6 foot by 12 swg but both have same reading from pins 31 + 32.I would really appreciate any help or input of knowledge as to what may be causing this ASD/Fuel relay problem.Can some kind sole with similar experience point me to a possible cause of this problem.Or even better suggest my next logical step in tracing this intermittent fault,as my TJ is now unreliable to drive.One further piece of info is i have checked for fault codes on the ignition key three turn procedure,only stored codes are 12 and 55 so no problem here.I have also confirmed this obd2 code reader attached, Innova 3100 older model no live date available. This also reads no other fault codes stored and no CEL light on dash panel So i will await and appreciate any update from this Jeep Wrangler TJ community. regards English guy 1

Screenshot (120).png


Jeep TJ 1997 pcm.png


Screenshot (162).png


Screenshot (134).png


my pdc box engine bay.JPG


ASD RELAY TEST.png


Screenshot (110).png
 
Last edited:
OP
E

English Guy 1

New Member
Apr 17, 2018
4
England, UK
Well it's update time so i will answer my own question as no one else has done this for me.It turned out to be a bad Camshaft sensor,which was triggering the ASD click and chatter.This also made the fuel pump run constantly some of the time,even with the key just in the on position not the run position.Hope this helps some other Jeep guy/gal out there.
 
  • Like
Reactions: Jerry Bransford
OP
E

English Guy 1

New Member
Apr 17, 2018
4
England, UK
Just thought i should add this extra info as may be of interest or significance to solving this issue.The whole time this engine stumbling issue was happening.I never once had the fault code 11 or 54 come up on the dash,after doing the ignition key three turn routine.I only ever saw code 12 and 55.very bizarre behaviour.
 
  • Like
Reactions: KCsTJ