Diagnosing Transmission Sound on 42RLE Transmission '04 TJ Sport 6Cyl

futhgar

Member
Joined
Mar 20, 2024
Messages
30
Location
Clearwater, FL
Hello everyone!

I'm trying to figure out what this sound could mean (in video) when my transmission shifts. I do not get any weird vibrations at all when it make the sound, nor am I getting hard shifting (was experiencing some rough shifting which went away after replacing faulty O2 1/2 Sensor which was coding with P0138). I am also not getting any transmission codes using a Bluedriver OBD2 reader, or any codes at all while idling or in transit. The oil does not smell burnt and is still reddish although a bit darker than new. I'm going to be replacing it's fluids and filter this weekend.

Has anyone experienced this or know the root cause?

42RLE Transmission on a 2004 TJ 6Cyl

 
  • Like
Reactions: enmanuelrs9999
Hello everyone!

I'm trying to figure out what this sound could mean (in video) when my transmission shifts. I do not get any weird vibrations at all when it make the sound, nor am I getting hard shifting (was experiencing some rough shifting which went away after replacing faulty O2 1/2 Sensor which was coding with P0138). I am also not getting any transmission codes using a Bluedriver OBD2 reader, or any codes at all while idling or in transit. The oil does not smell burnt and is still reddish although a bit darker than new. I'm going to be replacing it's fluids and filter this weekend.

Has anyone experienced this or know the root cause?

42RLE Transmission on a 2004 TJ 6Cyl


Found what the sound was? Does it happen when changing from 1 to 2?
 
We've not found out what the issue is, the Jeep seems to run just fine too we've not run into any issues. It makes the sound when shifting (automatic transmission) from first to second and back down. Does not make the sound in the higher gear changes but it does make a clicking sound when O/D is off and throttle is engaged / let-off. I have a separate post about that here:

https://wranglertjforum.com/threads/source-of-noise.77451/
 
  • Like
Reactions: enmanuelrs9999
We've not found out what the issue is, the Jeep seems to run just fine too we've not run into any issues. It makes the sound when shifting (automatic transmission) from first to second and back down. Does not make the sound in the higher gear changes but it does make a clicking sound when O/D is off and throttle is engaged / let-off. I have a separate post about that here:

https://wranglertjforum.com/threads/source-of-noise.77451/

I have something similar, in the same transmission as you, mine is a 2003. I will attach a couple of videos to see if it is similar to yours. The sound when moving the lever to R is the same as it makes when shifting from 1 to 2 and downshifts only in those shifts. And the other is an idle that according to me comes from the torque converter. I haven't changed the fluid or filter yet but I plan to do so, have you done it?

 
I've got the filter and fluid in stock to do the change soon. I'll post back once its done (we're moving so I've been tied up with other stuff and havent been able to work on the Jeep).
 
  • Like
Reactions: enmanuelrs9999
I've got the filter and fluid in stock to do the change soon. I'll post back once its done (we're moving so I've been tied up with other stuff and havent been able to work on the Jeep).

Please write an update when you do, I also have everything in hand but I haven't had time, if anything changes I will let you know