Front Hubs

Discussion in 'TJ General Discussion' started by Kevin E, Aug 12, 2017.

  1. Kevin E

    Kevin E TJ Enthusiast Supporting Member
    Thread Starter

    Location:
    Wharton, TX
    Replacing front wheel hubs and noticed my new bolts which are Crown and not Mopar are a bit longer. Is this going to cause any problems? Should I add a washer to back them out at all?
    20170812_163018_001-720x1280.jpg
     
  2. Rob5589

    Rob5589 I'm a dude playin a dude disguised as another dude Supporting Member

    Too close for me. Is there some reason you cannot use the original bolts?
     
  3. Kevin E

    Kevin E TJ Enthusiast Supporting Member
    Thread Starter

    Location:
    Wharton, TX
    The heads we're rounded off from P.O. not using the 12 point socket
     
  4. Kevin E

    Kevin E TJ Enthusiast Supporting Member
    Thread Starter

    Location:
    Wharton, TX
    It looks like they tried and gave up or something. The other hub wasn't touched so those came out and went back in no problem
     
  5. Kevin E

    Kevin E TJ Enthusiast Supporting Member
    Thread Starter

    Location:
    Wharton, TX
    Found OME bolts so ordered them. I don't really like it myself.
     
  6. Rob5589

    Rob5589 I'm a dude playin a dude disguised as another dude Supporting Member

    :emoji_thumbsup:Good idea
     
  7. Ahoragi

    Ahoragi TJ Addict

    I don't see a problem with running those bolts. They are the wrong length but will not cause any issues.
     

Share This Page