Help Diangnosing P0161, P0158, P0740

JeepGirl1013

TJ Enthusiast
Supporting Member
Joined
Jan 12, 2024
Messages
133
Location
Missouri
Ok so I need a new O2 sensor- as does everyone. But the P0158 just popped: O2 sensor circuit high voltage. Is this a sign I really need to replace the O2 sensor? Is there anything else I should be looking at?

P0740 just started for me this week. I have been experiencing a long crank time, unrelated to the fuel pump (I just changed it). I have replaced spark plugs and am checking out the injectors but so far that all seems fine. Could P0740 possibly be causing my long crank issues? I’m not having any other issues with the transmission, or any of the symptoms I see online when I look up this code.

However, I discovered yesterday that the breather valve on the TC is completely disconnected and I am going to replace that hose. Could this possibly cause P0740?
 
Breather missing won't throw a code but take a look at or replace the ATF.

Check your fuel pressure... especially after it's sat a while. (Why I just gave up and installed a pressure gauge on the fuel rail.

And change the O2 sensor, clear the codes and see what happens.

-Mac
 
Breather missing won't throw a code but take a look at or replace the ATF.

Check your fuel pressure... especially after it's sat a while. (Why I just gave up and installed a pressure gauge on the fuel rail.

And change the O2 sensor, clear the codes and see what happens.

-Mac

I just replaced the atf in Feb. it looks good. And while I have a tiny leak I haven’t had to refill it since I changed it.

Will check the fuel pressure. Thanks!
 
  • Like
Reactions: macleanflood