Hunting for part numbers

thedustyboot

A drug habit would be cheaper
Original poster
Supporting Member
Lifetime Supporting Member
Joined
Feb 20, 2022
Messages
190
Location
Powell River, BC
Is there anyone on the forum who knows/has the part number for the front fender side marker socket? I have a 1997 SE and it needs the socket with three cam thingies, can only seem to find them with four...

side marker.jpg


302527765_3167654086833616_1001465259671828313_n.jpg
 
Last edited:
Is this another quirk of the 97 models? We had a few light bulbs listed in the electrical section here, but looks like I may need to add this one.
 
@SSTJ @LittleTankTJ

Those parts finally came in, ordered the same as what @LittleTankTJ linked in post #2. They were not the right part unfortunately.. They had four tabs on them rather than three which is what I need. Do either of you have a link/part number for the side marker housing that will match the side marker socket I ordered?
 
@SSTJ @LittleTankTJ

Those parts finally came in, ordered the same as what @LittleTankTJ linked in post #2. They were not the right part unfortunately.. They had four tabs on them rather than three which is what I need. Do either of you have a link/part number for the side marker housing that will match the side marker socket I ordered?
What p/n is incorrect?
 
@SSTJ @LittleTankTJ

Those parts finally came in, ordered the same as what @LittleTankTJ linked in post #2. They were not the right part unfortunately.. They had four tabs on them rather than three which is what I need. Do either of you have a link/part number for the side marker housing that will match the side marker socket I ordered?

Will it fit if you grind off the lower tab, leaving 3? It looks like the 3 remaining will be oriented correctly.
 
@taylormade73 I'll give that a shot and see if it solves the issue.

@Jerry Bransford I couldn't find a PN on the OEM socket nor can I find anything online that matches what I need. Probably comes down to one of those oddities with the '97.

@SSTJ Yea I think that will be the backup plan if I can't modify the ones I ordered (which were the same ones linked by @LittleTankTJ.
 
  • Like
Reactions: taylormade73
Keep us posted! I'll try to remove mine sometime to see if I have what you have or what LittleTank has.
 
@taylormade73 I'll give that a shot and see if it solves the issue.

@Jerry Bransford I couldn't find a PN on the OEM socket nor can I find anything online that matches what I need. Probably comes down to one of those oddities with the '97.

@SSTJ Yea I think that will be the backup plan if I can't modify the ones I ordered (which were the same ones linked by @LittleTankTJ.

@thedustyboot did this part work for you? I ordered it and am still having issues. I get the same voltage as driver side marker light, but not getting enough to light passenger bulb. I crimped the connects to old wiring. Saw YouTube video that said it should be soldered connections. Did you solder yours?
 
@thedustyboot did this part work for you? I ordered it and am still having issues. I get the same voltage as driver side marker light, but not getting enough to light passenger bulb. I crimped the connects to old wiring. Saw YouTube video that said it should be soldered connections. Did you solder yours?

I haven't gotten to it yet, still away for work (shift work life:rolleyes:) I'll get around to it monday the 7th when I'm back home.

Mine worked reasonably well but I switched to LED bulbs and that probably disturbed the corroded connectors and kicked off this whole debacle.
 
I haven't gotten to it yet, still away for work (shift work life:rolleyes:) I'll get around to it monday the 7th when I'm back home.

Mine worked reasonably well but I switched to LED bulbs and that probably disturbed the corroded connectors and kicked off this whole debacle.

What is your actual issue? Is the bulb only working in some conditions? You can’t just swap straight to LEDs…so you may have an issue related to the LEDs and not the socket.
 
What is your actual issue? Is the bulb only working in some conditions? You can’t just swap straight to LEDs…so you may have an issue related to the LEDs and not the socket.

It is the socket. I should have included a pic of what they looked like without the bulb but they're pretty nasty. I think what I was trying to say in my last reply was that by taking out the old bulb, any remaining contact from bulb to socket connectors was disturbed due to the amount of crud and corrosion in there. Plus after 20 or so years they're probably due to be changed anyway due to the amount of dirt and water they get hit with on the regular.
 
It is the socket. I should have included a pic of what they looked like without the bulb but they're pretty nasty. I think what I was trying to say in my last reply was that by taking out the old bulb, any remaining contact from bulb to socket connectors was disturbed due to the amount of crud and corrosion in there. Plus after 20 or so years they're probably due to be changed anyway due to the amount of dirt and water they get hit with on the regular.

Fair enough, but once you do finally get a proper socket, I would not expect the LEDs to work properly at all. Jeeps are not wired properly for them and to fix it you need to rewire the side markers. This happens to the side markers when you put LEDs in the front turn signals regardless (no matter what bulb is in side marker). Issues related to putting a bulb in the side marker depends on if the LEDs are non polar or not. Non polar will work fine but polar will not because the current in the side markers goes both ways from the factory.
 
That's good to know. I did change out the turn signal relay and it all worked just fine for a short while. So I'm still going with pooched sockets as the main cause of the issue.

And this discussion with definitely help other TJ owners down the road if someone runs into this issue 👌
 
@SSTJ @LittleTankTJ

Those parts finally came in, ordered the same as what @LittleTankTJ linked in post #2. They were not the right part unfortunately.. They had four tabs on them rather than three which is what I need. Do either of you have a link/part number for the side marker housing that will match the side marker socket I ordered?

Will it work if you cut one tab off?