TJ Fest 2021
Join us in Moab, Utah from 4/24/2021 to 5/1/2021 for the first annual TJ Fest 2021. Click here for more information.

Jeep has broken down


GOAD

New Member
Joined
Jul 13, 2019
Messages
2
Location
US
2006 tj 4.0L I6 180k mileage

The jeep began to miss at idle and under load 2 days ago while my wife was driving to the store. She arrived at the store and the jeep would crank but not start. Called a tow company, 45 minutes later they arrived, he cranked the jeep and it started right up. He followed her home (2 miles). I arrive home 5 minutes later the jeep will not start, crank yes but not start. 1 hour later it started but had a terrible miss, unresponsive throttle when accelerator was depressed, now it will not start at all (hot or cold).

Btw, via obdII and key dance, no codes.

I began replacing items...... in as logical manner as possible.

Within the last 3 months (had a worn wire repaired).....
New alternator
New battery
Sent computer to cardone with vin and had it updated with latest firmware

The last 2 days....
1. Both upstream O2 sensors
2. TPS
3. Confirmed with vacuum pump and multimeter MAP sensor is good
4. Cleaned throttle body
5. The IAC seems to be operating and it was cleaned

Anyone else experience this? Any assistance would be greatly appreciated.

I was thinking crankshaft position sensor but the vehicle is producing no codes.







Sent from my SM-G930T using Tapatalk
 
OP
G

GOAD

New Member
Joined
Jul 13, 2019
Messages
2
Location
US
Will the IAC throw a code? I know it should but will it always?

Sent from my SM-G930T using Tapatalk
 

Fughuert

TJ Enthusiast
Joined
Nov 26, 2018
Messages
149
Location
New England
Mine didn’t throw a code and I had to manually idle it with the throttle or it’d stall.

If it’s just the iac it should start if you hold the throttle.