Jeep not starting, found some wires not plugged in and Im not sure what they are?


MIKE2KTJ

New Member
Joined
Mar 25, 2021
Messages
6
Location
Michigan
Hi all,
I have a 2000 Jeep with 157000 miles on it and I've been having some trouble with it starting and running. I've owned the car for about 2 years now and for the whole time that I've owned it It almost never starts on the first crank, but always on the second. there are some other problems which I think are probably related to this, sometimes when I'm accelerating the engine seems to cut out for half a second then continue a couple times in a row, also it has stalled out on me a couple of times when driving and refused to start back up. I never got around to fixing any of this until the problem killed the starter motor.

So far in trying to fix this problem I have replaced the starter, fuel pump, Throttle position Sensor, crankshaft position sensor, and the spark plugs.

I have 2 questions for you all...
First what do you think could be causing this problem, any ideas?
Second, today when I was under the car doing the crankshaft sensor I noticed 2 sparkplug looking things coming out of the exaust tubes right next to the manifold, they were connected to wires that led to connecters that had been cut off about an inch after them. Ive attached some pictures that are pretty poor quality but I hope that between the pictures and my description you can tell me what it is and some suggestions about how to fix it.
Thank you for your time,Mike
IMG_3798.jpg
IMG_3801.jpg
 

glowell222

TJ Enthusiast
Supporting Member
Joined
Nov 10, 2019
Messages
531
Location
Northern VA
Those are oxygen sensors. Without these sensors your engine will run very poorly, and your fuel mileage will be awful. Do you have an OBDII code scanner? I suggest to start there and see what codes you are getting.
 
OP
M

MIKE2KTJ

New Member
Joined
Mar 25, 2021
Messages
6
Location
Michigan
ok, thats what I thought they were. and just to confirm those are the same thing as o2 Sensors right? or is that a different thing?
 

glowell222

TJ Enthusiast
Supporting Member
Joined
Nov 10, 2019
Messages
531
Location
Northern VA
ok, thats what I thought they were. and just to confirm those are the same thing as o2 Sensors right? or is that a different thing?
It's the same thing. I suggest to buy or borrow from a local auto parts store their code scanner, scan your Jeep and see what codes you are getting. Also, there is an entire thread about the O2 sensors, and I will dig up the link for you. It's important to read and purchase the correct sensors, otherwise it will just be more headaches. The scan port is under the driver's side kick panel, far left of the steering column. I have included the O2 thread below, as well as a won't start thread. These are so helpful.

O2 Sensor Thread

TJ Won't Start Thread