Johnny Joint Clunk / Front End Clunk

@connor grimes @Jerry Bransford @SkylinesSuck

Should there be any felt movement in the ball joints? I just tried check both drivers side and passenger side by jacking each tire off the ground and taking a crowbar and prying up from underneath the tire. While doing this I would put my fingers on the ball joints and feel for movement. The driver side where I think the clunk is, I can feel some movement for sure in the upper joint and a small amount of movement in the lower joint. Lower is barely any but upper definitely has some movement. Passenger side I don’t feel any movement in either joint.

These are spicer/Dana joints with less than 10k on them

 
Last edited:
I think zero noise or movement is the gold standard for ball joints, but that movement on the lower control arm is almost certainly your clunk. The hole in the mount is slotted to allow for some adjustment from the factory via an eccentric bolt. BMB sells a set of fancy washers for basically getting rid of the slot and helping hold grease in. I bought a set while chasing my clunk and while it obviously didn't fix my issue, they are worth a look for you I think.
 
https://blackmagicbrakes.com/ols/products/johnny-joint-washers-set-of-4

rs=w_600,h_600.jpeg
 
  • Like
Reactions: connor grimes
Experienced something similar in my 08 JK. An intermittent clunking noise for 6 months or so that gradually got worse, but did not affect driving and was very hard to find. Turned out to be the CV Joint. Even when it failed it was clunking loudly and convinced me it must be the CV joint, then the next time I got in the jeep it drove fine with no noise. Decided to take it off and check it and it fell apart in my hands once unbolted. Maybe similar issue?
 
So I just got back from 7 days in the Mts running rough dirt roads. By the end of the trip the clunking has returned. Would it be possible I’m dealing with a bolt that won’t hold torque? Is it possible that the current bolt is too short as well? @SkylinesSuck
 
The bolt is engaging all the threads on the nut, right? If so, I don't see how it could be too short. Did you get back up under there and try to torque it down again? What did you torque it to?
 
That’s what the bolt looks like fully torqued. It always seemed a little on the short side, but wasn’t certain if it was or not. I torqued to 130 originally. I just retorqued it to 150 today.

IMG_7532.png
 
Re-reading your original post, looks like these are Savvy arms from 2 years ago. I ordered my Savvy kit in Aug 2020 and it came with the hardware they could get at the time (COVID) - but wasn't right for thread engagement, and my original hardware look like yours.

Here is the original nuts engaging the original bolts:

PXL_20230909_210421535.jpg


PXL_20230909_210431403.jpg


You'll note your kit, like these pics, show a nylocs and extra-thick washers. You want at least 2 full threads to consider a bolt/nut fully engaged.

I emailed Gerald and he shipped out new nuts & washers (at no cost) that they include these days (and apparently before the COVID inventory-restricting days). I let him know I did not feel safe with my family in this Jeep without proper thread engagement. Despite other Savvy issues on availability (these days) and no stickers (contact Jerry), Gerald was very responsive on my concerns!

PXL_20231006_223138539.jpg


Much thinner (more typical) washers & non-nylon lock nuts resulted in much better thread engagement!

Recommend you reach out to Gerald (gman savvyoffroad.com) for a new set of washers & nuts.

If you didn't put in BMB alignment slot fillers - recommend those too. (I had a HP Dana 30 & them put in new lowers - so didn't have an alignment slot to concern myself with).

Can't say it's your issue but it is a potential future problem. ;)
 
He said he has those BMB washers already. I strongly suspected that was the issue but I guess not. It seems like he's barking up the right tree though since messing with it fixed the clunk at least for a little while.
 
He said he has those BMB washers already. I strongly suspected that was the issue but I guess not. It seems like he's barking up the right tree though since messing with it fixed the clunk at least for a little while.

I can't keep threads straight... lol. I'm still concerned on using those thick washers and nylocs - not enough thread engagement. May not be this new clunk but I don't want a future failed of a nut twisting off for anyone... That's what cause me to reach out to Gerald and the new setup has much better thread engagement.
 
My bolts all have at least a few threads past the nut and I use Stover type (all metal with deformed thread) locknuts.

You're sure the bolt is class 10.9? And make sure you're using the correct torque specs. In addition to size and strength class, they vary based on thread pitch and whether the threads are lubricated. If it's been over-torqued, it's cooked and needs to be replaced.
 
  • Like
Reactions: FarFire70