Kim's 99 Jeep Wrangler Build Thread

OP
KimsJeep

KimsJeep

TJ Enthusiast
Supporting Member
Jan 5, 2019
246
Sacramento
LOL, they don't mind it. :D.

Yah, I contacted them I even took pics of the ones that they had in the advertisement and you can see they are different and look a lot better then the ones I got. The one that is broken down was so really discolored too. I did clean them up and they look a bit better as for as that goes, but not much else. The passenger one is actually in decent shape as far as the material and build, but that is the one that broke the tab off the end.

View attachment 75948

View attachment 75949

View attachment 75950

View attachment 75951

View attachment 75952
Just an update on this. I ended up leaving a bad review on them today. I just got off the phone and the guy picked out a different set as we talked and then got them out for shipping. He also told me just to throw away the set I have now. So I should be getting a better set in a few days. Will post when I get them.
 
OP
KimsJeep

KimsJeep

TJ Enthusiast
Supporting Member
Jan 5, 2019
246
Sacramento
Just a small update. But first, I went for a drive in the country to take some pics of the Jeep last weekend. Here are some of my favorites. :D

kEXWRCTWR1SYsiCLpSKxpw_zpssg4nmoqj.jpg


zXiAMq8HTrauiYRsYIviuA_zpsferdepjf.jpg


jqlpZ0PT6XMJ8qOLCDg_zpsugjwt3er.jpg


cRuO8A93SqqzFcZHpCSjTQ_zpsf27owqxx.jpg


ZmVj8t1dQ1eAYaAzrwPxJw_zpsoueippzj.jpg


TdaOOQmQqulzCEyEbYnA_zpsmskjxubi.jpg


Just got a little dirty. Actually found some pretty deep puddles on some of the gravel roads.

fullsizeoutput_349c_zpsdy5osp4z.jpg


C1FtnUfZSECbJgoOOdjH0w_zpsqdnuomey.jpg


And now my update. :D Installed the windshield decal I made and also the grille inserts. :D

KjhrF1zqSeehA9uke8cNOQ_zpsik0qvu7l.jpg


I am so happy with the results. :D Now I need to save for the turn signal lenses and then the front should be done, for now. LOL
 
OP
KimsJeep

KimsJeep

TJ Enthusiast
Supporting Member
Jan 5, 2019
246
Sacramento
Was anyone hurt in the plane crash?
I think it is yard art. I was going to go park by it for the pic, but then I noticed the house. The motor appears to be out of it. I think it is just a shell. I guess I should go back with a better camera with a zoom lens so I can get better pics of it.

t+XoJ9IoTOusF2gb0MK5Gw.jpg
 
Reactions: Kiwi TJ
OP
KimsJeep

KimsJeep

TJ Enthusiast
Supporting Member
Jan 5, 2019
246
Sacramento
I liked another members stereo and so I decided to get one for my Jeep. Got it yesterday and installed it today.

77684


I liked it because it had a changeable color display and also it connects to my iPhone. It comes with a mic so I decided to run it over to the roll bar and attached it to the padding.

77685


I figured that was the best spot for the mic but I do realize it probably won't do to much good when the top is down. The only thing I wish the stereo would do that it doesn't is, have the calls come through all speakers. They only come through to fronts. I will just have to make sure I have the volume up on my phone as well as the radio.

I also installed my bumper ends.

77686


I used plastic pop rivets to hold them on. Still need to sand the end off though. Plastic ones don't seem to break off like the normal rivets do.

I also ordered some personalized plates and ordered something off Ebay that I can't wait to share with you all. You will get a kick out of it. LOL
 
Last edited:
OP
KimsJeep

KimsJeep

TJ Enthusiast
Supporting Member
Jan 5, 2019
246
Sacramento
Ok, trying again. LOL Computer issues. Anyway, I wanted to update on the visors from DeadJeep. The replacement set came in and I am super happy with them. Much nicer then the other set.

fullsizeoutput_34fc.jpeg


fullsizeoutput_34fe.jpeg


tyE2lQUQTrGiq0w%krlPQQ.jpg
 
Reactions: derekmac
OP
KimsJeep

KimsJeep

TJ Enthusiast
Supporting Member
Jan 5, 2019
246
Sacramento
Well kind of. I don’t know why it worked, but I came back into this thread and some of the words and pics were still in the reply box, so I hit post reply. It did but it didn’t have all of what I wrote. I tried to edit it, and add the missing text and I go the error message. Tried to go back to my thread in the other forum and it wouldn’t load. Then for the next hour I couldn’t get on the forum. I tried safari, google chrome and my phone. Just kept getting the page won’t load. I finally gave up and was going to bed and thought, I’ll try the iPad. And it is working on it for now. Have no clue what is going on.

The missing text in the post above was explaining that the purple people eater stuffy is my Jeep’s new mascot. LOL

Anyway. I sure hope that what ever the issue is, it will fix itself soon. So frustrating that I can’t post or can’t even get the forum to load all together.