Low oil pressure caused by sludge in oil?

OP
CODE5

CODE5

Member
Supporting Member
Joined
Apr 28, 2022
Messages
87
Location
Alabama
Well, I drained the oil containing engine flush - the oil came out blackish, not chocolate colored thank goodness. I installed a new oil filter and poured in 10w-30 conventional oil. The engine is ticking just like before. I used some wooden dowels to pinpoint the ticking of the engine... It is coming from the block, not the headers, and not the valve cover either.

Here's my question now... When I did my head install I placed everything back on the head as it was when I removed it ( rockers in their exact places along with the pushrods) I'm now reading about the whole putting cylinder 1 to TDC and starting from there... Did I mess up by not putting the engine to TDC? I don't remember any of my rockers being loose before I put the valve cover back on.

I feel like I should open the valve cover back up and at least put it at TDC for each cylinder and check the tightness. I'd hate for my ticking to be something simple as that.

 
Last edited:

Rickyd

TJ Enthusiast
Supporting Member
Joined
Jan 2, 2020
Messages
397
Location
North coast,CA
Valvetrain isn't adjustable. Possibly you could get better torque measurements by tightening rocker bolts with no strain on the pushrods. My money is on the famous ticking 4.0l lifters. Or leaking exhaust from the reinstall. If its lifters I'd leave it alone. Results of new cam and lifters on these amc motors could range from quiet running to catastrophic engine failure.....replacement part quality is terrible.
 
OP
CODE5

CODE5

Member
Supporting Member
Joined
Apr 28, 2022
Messages
87
Location
Alabama
Valvetrain isn't adjustable. Possibly you could get better torque measurements by tightening rocker bolts with no strain on the pushrods. My money is on the famous ticking 4.0l lifters. Or leaking exhaust from the reinstall. If its lifters I'd leave it alone. Results of new cam and lifters on these amc motors could range from quiet running to catastrophic engine failure.....replacement part quality is terrible.

If it’s lifters, damn these things are loud… This ticking is louder than my engine when I’m driving 55mph… worries me it sounds like the top end is getting half the oil it used to from all the “clickty-clacking”

The sound reminds me of a baseball card hitting the spoke on a bicycle wheel. The faster I go, the faster it gets 🤣😬
 
OP
CODE5

CODE5

Member
Supporting Member
Joined
Apr 28, 2022
Messages
87
Location
Alabama
Update as of Sunday evening… Just running 10w-30 with a new filter. Took it for a ride to the grocery store (10 miles) on the way back I stopped at a red light and the infamous “check gauges” came on with little over 5-6 psi oil pressure. I revved up to 1100 rpms and it went back up to 10-15 psi then to 20 when I was going 55 mph… Seems to sound worse.

I did drive it a little harder hoping that would solve it but no, it’s like a ball and chain. Oil pan is coming off when I get the time after deer season (hunting guide)


 
  • Sad
Reactions: hear and Squatch