Misfiring and bucking from new to me 97 TJ 2.5


scoled1992

New Member
Joined
Mar 5, 2021
Messages
3
Location
IN
I was in about 3rd gear yesterday and the jeep started misfiring and CEL flashing. I came to stop to pull out, uphill of course and could not get any power in gear. I had to roll back down hill and shift to second. Got a another run at the hill fairly steep. Was unable to get the Jeep to the top without slipping the clutch and boy was it running rough. Practically coasted home. The first time this happened I was taking off in first gear and just thought I was a out of practice with clutch. Then it started happening more frequently.

We bought the jeep with 237K miles so I knew it would need some love.

After some research and with the help of this forum my first thought was to try the Crankshaft Position Sensor.

Any help would be appreciated.

Worth noting. The CEL flashes, but doesn't stay lit. The Antifreeze was low when I bought it and the owner had some in the back. The oil pressure will randomly drop, but he added a manual gauge and it reads normal. At idle the engine with sometimes change rev RPMs..almost like surging.
 

Chris

Administrator
Staff Member
Ride of the Month Winner
Joined
Sep 28, 2015
Messages
62,411
Location
Florence, AZ
Scan it with an OBDII reader and tell us what codes it's throwing.

If you don't have one, go to any local auto part store and they'll scan it for free.
 
OP
scoled1992

scoled1992

New Member
Joined
Mar 5, 2021
Messages
3
Location
IN
No code, but now won't start. Seems to be electrical now the dash doesn't do much of anything, but oil pressure when turned to the on position. I was driving around yesterday and the voltage read 18 plus with "Check Gauges" light came on.