P0344 Code

I recently replaced my Cam Position Sensor (with a Mopar part) and threw a P0344 code; the jeep (2005 LJ) also began to stutter around 2500 RPM driving down the street.

I had been chasing down a P0172 code and replacing the Cam sensor was something I read somewhere that would help. It seems to have not helped at all!

I still had the old part, so I put that back in. Still have the code, but no stuttering/surging when driving now. Any ideas on what next steps could be?

Thanks!


Sent from my iPad using Tapatalk
 

Paul Land

Member
Oct 3, 2018
98
New Jersey
I recently replaced my Cam Position Sensor (with a Mopar part) and threw a P0344 code; the jeep (2005 LJ) also began to stutter around 2500 RPM driving down the street.

I had been chasing down a P0172 code and replacing the Cam sensor was something I read somewhere that would help. It seems to have not helped at all!

I still had the old part, so I put that back in. Still have the code, but no stuttering/surging when driving now. Any ideas on what next steps could be?

Thanks!


Sent from my iPad using Tapatalk
Could be bad O2 sensor(s) Mine want bad got same S/S. Easy Check of O2 Sensor Hit tip with propane and use volt-meter to see if its faulty
 
Thanks Paul.

I recently changed all my O2 sensors too (due to the P0172 code I started with). All to the NTK recommended brand.

MAP sensor has been replaced, IAC cleaned multiple times. The P0172 code has yet to come back (touch wood)...

Perhaps I have a loose connection or a worn wire somewhere?

I’m open to any and all suggestions!


Sent from my iPad using Tapatalk
 

Zaythedad

Member
Oct 26, 2018
62
Pueblo Colorado
I feel ya man I'm losing my mind over here.



I have a 2.5L 2000tj and I was pulling codes for either a bad CPK or can sensor.
Read some threads and watched some videos was recommended that I changed the cpk.
I did boom pulled the codes 2 days later then I noticed my distributor was super loose to move got it put back in the right spot and tightened up and run good for two. Three weeks
Last week I'm driving about 60-70 mph in 4th about 28k-35k rpms my Jeep like jumped kinda felt like a missfire and kept doing it every now and then when I accelerated.
Take it to my local buddy and Midas and we end up changing my whole distributor set up had 3 cracked plugs changed those as well.
Went home drove for a day and then boom did it again on the same amount of speed and rpms.