Right rear tail light; fast blink on dash, no signal light in housing, no light when light turned on, and no hazard light

mthornt

New Member
Joined
Aug 30, 2016
Messages
24
hi, first my Jeep TJ is a 2001. I'm trying to troubleshoot the problem posted in the subject. I've replaced the bulb for both the light/signal and the brake light and nothing works. I guess I don't know where to start other than the bulbs. The left (driver) side is fine and works as it should. Front signals work and lights go on up there. Any help would be appreciated

Mark
 
hi, first my Jeep TJ is a 2001. I'm trying to troubleshoot the problem posted in the subject. I've replaced the bulb for both the light/signal and the brake light and nothing works. I guess I don't know where to start other than the bulbs. The left (driver) side is fine and works as it should. Front signals work and lights go on up there. Any help would be appreciated

Mark

You can remove the 3 tail light housing body bolts to access the tail light harness connector looking for oxidation inside the connector and test for voltages when parking, brake and turn signals are used; this will determine if the problem is in the MFS (multi function switch) or elsewhere.
 
hi, first my Jeep TJ is a 2001. I'm trying to troubleshoot the problem posted in the subject. I've replaced the bulb for both the light/signal and the brake light and nothing works.
Was it workin BEFORE you replaced them?
Did you install the correct style OEM bulbs or different??

If 3 of the 4 work, check the ground for the bad one, and get a Fluke to test for voltage where it should be