Transmission Problem

iKrea

New Member
Joined
Jan 17, 2024
Messages
22
Location
Ontario
Sow my current issue is that I just went on a little trip with my tj and upon coming back I theres this semi loud rattle/hitting sound, something is hitting on my transmission and I dont know what it is, I recently did a fluid change on my transmission and it has been shifting like butter, the gears engage nice, no actual transmission issue other than this very alarming loud rattling sound and I also thing my car is currently suck in 4WDH and won't get into 2H since all the sounds that happen while im in 4H are currently happening but even if thats the case why is my gear stick kinda shaking more than usual and when you place your hand on it you feel something hittin, could it possibly be a transfer case problem/bad transfer case? someone help me
 
Go under the Jeep and start checking the transfercase skidplate bolts (6), the exhaust hanger attached near the transmission mount and the transmission mount bolts (4 on transmission) and skid plate nuts (4) to ensure they are tight.

Much love I will do that and check back with you
 
Go under the Jeep and start checking the transfercase skidplate bolts (6), the exhaust hanger attached near the transmission mount and the transmission mount bolts (4 on transmission) and skid plate nuts (4) to ensure they are tight.

I just checked a bunch of bolts under and everything seems pretty dang tight, is it normal for the skid plate under my transfer case is holding up my entire transmission in proper place? also found two very loose heat shields on my cat converters right next to my trans, would that be the cause of the the thing i feel hitting on my transmission?
 
I would also check the condition of the transmission mount rubber; it may be separated causing a lot of transmission movement.
The skid plate is bolted to the frame rails and the rubber transmission mount bolts to the transmission; the skidplate keeps the transmission in place.
 
  • Like
Reactions: macleanflood
I would also check the condition of the transmission mount rubber; it may be separated causing a lot of transmission movement.
The skid plate is bolted to the frame rails and the rubber transmission mount bolts to the transmission; the skidplate keeps the transmission in place.

Okay I just checked the skid plate and whatever holds the transmission used a jack to see if anything is out of the ordinary and so far so good
I would also check the condition of the transmission mount rubber; it may be separated causing a lot of transmission movement.
The skid plate is bolted to the frame rails and the rubber transmission mount bolts to the transmission; the skidplate keeps the transmission in place.

Update I’m 100% sure i’m in 4wd and that’s why something feels like it’s hitting my tranny in gear and squeaking I think i’m going to jack up my jeep take the transfer case out and take a look inside if it still won’t go into 2H and also figure out why my 4h is all f’ed up, I would like to add that in 4L when driving the car bogs back and forth like crazy so either way am I right to think this could very well be a T case problem?
 
IF you are in 4WD and have driven on asphalt or concrete; then the transfercase is more than likely binding up which is why you can’t get the transfercase out of 4WD. Place the transmission in Reverse and drive a very short distance backwards. That should unbind the transfercase and allow you to shift back into 2WD.
 
IF you are in 4WD and have driven on asphalt or concrete; then the transfercase is more than likely binding up which is why you can’t get the transfercase out of 4WD. Place the transmission in Reverse and drive a very short distance backwards. That should unbind the transfercase and allow you to shift back into 2WD.

I adjusted the shift linkage too and managed to get it where it goes into 2H better and etc, the squeaking is violently prevelant when in 4wd, I'm going to take it to a mechanic friend of mine after everything I still can't figure out what exactly is hitting on the Transmission, since the rattle/sound still happens when I drive and press in the clutch
 
My bet is on the front driveshaft…

Maybe same I did everything and its still there so only thing left is to get my tranny fixed incase I fucked it up which I heavily doubt and the front driveshaft has old U joints and slightly shakes when you like try to move it
 
Maybe same I did everything and its still there so only thing left is to get my tranny fixed incase I fucked it up which I heavily doubt and the front driveshaft has old U joints and slightly shakes when you like try to move it

If there’s movement, especially at the cardon joint, I’d drop it, and 1. See if the issue goes away, and 2. Until you get the shaft rebuilt… if that cardon joint fails it will take other things with it… things like transfer case, possibly transmission, etc…
 
IF the noise is coming from the front driveshaft; then the squeaking is probably coming from either a dry U joint or a dry DC centering ball.
As posted above… IF the noise goes away after the front driveshaft is removed; then the problem is the front driveshaft.
 
My bet is on the front driveshaft…

DING DING DING!!! it’s indeed my front drive shaft that is TERRIBLY f’ed up, it’s like wobbling VERYYY badly and this is ALSO coming from my very very talented filipino mechanic friend, anymore driving and it would probably genuinely blown off, at both joints, just to save time, work and peace of mind of a new part since the car is 20 years old, I just ordered an entirely new prop shaft with new joints and etc