Troubleshoot a "once fire" and now "no-fire" scenario"

Noted. I'm going to try to get my hands on an oscilloscope this week but I feel as if NEW KPS & CPS sensor replacement should have ruled them out. I know it's not best practice to throw parts at it but I did so, anyways.

What I can't seem to find in the FSM, is what "PCM inputs" tell the PCM to close the injector driver circuits and drive injector pulse. I know the motor has spark. It fires with starting fluid. I know the motor has fuel at the fuel rail. The injectors have 12v through a closed ASD relay. All things are pointing towards SKIM.
I don’t have a skim-equipped jeep, but I thought skim would let it run for a few seconds and then would kill it via ASD.

But if you know it will fire with starter fluid that tells me you have spark & therefore your crank & cam sensors are ok. I don’t know how the injectors actually work but have you verified all that wiring is good? I would’ve expected that seeing 12V there was likely enough to assume the injectors would work. But maybe not?
Just thinking more…. Unplug all the stuff that it doesn’t need to fire up, and try again.

O2 sensors
Pretty sure IAC?
Pretty sure TPS?
Oil pressure

And while you’re at it, verify that you don’t have twisted up bare wires at each of those connectors.

If it still doesn’t start I would add back the TPS & IAC first and then try. It doesn’t need everything that is plugged in, so let’s work on finding the minimum set of things to allow it to start. We should have this documented anyway, honestly.
  • Like
Reactions: macleanflood
OK, I'm almost at wits end. I unplugged and inspected just about every sensor wiring mentioned above. I didn't see anything out of the ordinary. I went back to the basics. Fuel pressure is good at the rail. I bought a noid test light. To my disbelief, all six injectors are getting power and driver command to light up the noid, when cranking. I pulled the fuel rail, with the injectors, and witnessed fuel spray out of each injector while cranking. I cleaned & re-gapped each plug. Still nothing but starter fluid turns it over. It's getting spark and fuel.. How can this Jeep not run??!
No compression.

Either no valves...or so completely out of time the valves are opening when the plugs are firing.

Dex on YouTube... think he's going by DexJs now...had a Mexican cam in a 4.0 with lobes that were in wrong places. Took him months of troubleshooting to figure it out.

No compression.

Either no valves...or so completely out of time the valves are opening when the plugs are firing.

Dex on YouTube... think he's going by DexJs now...had a Mexican cam in a 4.0 with lobes that were in wrong places. Took him months of troubleshooting to figure it out.


I tested compression just when the symptoms started a couple weeks ago. All six cylinders were between 165 and 173 psi.
Exactly... timing... you're getting compression but it's out of time with fuel and spark.


Yeah, if you have spark, fuel, compression, & air (I assume you’ve got the throttle body uncovered at this point, if you’re spraying starter fluid in), my next guess would be that you don’t have them all at the right time.

Find TDC, go through the dizzy reset process. You dont have a distributor on the 03, but the OPDA also needs to be timed, and I’m willing to bet it’s a very similar process. This thread talks about it, I'm sure there are others:

And since we’re at this point it might be worth bringing up some other bizarre stuff like do you have the right flexplate/flywheel (I forget which trans you're using) for the crank sensor? I want to say they changed the geometry of the tone ring in the later years...although I can't even find a flexplate listed on RockAuto for 2003+ (does the 42RLE not use a flexplate??). I also remember seeing a lengthy writeup somewhere about a guy who ended up discovering that either the opda tone ring was out of phase with the drive gear, or maybe the sensor itself was on the edge of spec and was causing a no-start condition.

One way or another this definitely sounds like a timing issue.
You also mentioned looking at the waveform of the cam & crank on a scope. Here's a video on testing the cam sensor on an 02 (which will be pretty similar to your 03). I skipped ahead to where I used a cheap scope to verify the waveform of the cam sensor while running. You can do the exact same thing on the crank sensor. In a perfect world I'd have a dual input scope so you can see the signals relative phase. Which really only helps if we know how they need to be...which is on my list of things to figure out one day.

Somewhat related to this, since I mentioned it in my post above about the flexplate...

Since you swapped from an 03 to an 03 it might not be a thing, but the flexplate acts as a tone ring for the crank sensor. Earlier TJ's had window pattern that could tell the computer where it was in the cycle. The later ones didn't have that, but instead had a timing learn process that I really don't know much about. The cam sensor is similar, but I don't believe it changed other than when they went from dizzy to opda.

From a 97-02, which, perhaps not coincidentally, is for a 32RH. The 03 & 04 is extremely similar in function, but must be slightly different for the 42RLE.

This is from an 05-06, which corresponds to the 42RLE.

I know even less about manual transmission than I do about automatics, but my understanding is they function similarly. So... is it possible you have the wrong flywheel or flexplate? And then is it necessary to "time" them to the crank? I don't know since I've never had a flexplate off an engine before. I mean, the answer is YES, it must be timed, but maybe the bolt pattern enforces the correct timing or maybe there is a process. I wouldn't even bring it up except that you've tried a bunch and we've kinda zeroed in on timing as the culprit.
A little more history to help the cause. The 03 donor was running and driving. Pulled into my shop for the teardown. I did a minor teardown of the motor. Flywheel was pulled, new gaskets, freeze plugs, RMS, water pump, thermostat, timing chain.. the usual. Crankshaft and Camshaft was indexed for new timing chain. Flywheel is original (from M/T) and was indexed to the crank (although I don't think this is necessary). So, it's hard to think timing is 180 degrees off. I did not pull the OPDA..

This 03 "drivetrain" was swapped into an earlier model LJ. Previously, it had the 03 motor & PCM but had the 05 tank, evap, injectors and fuel rail. It ran and drove but ran rich. Investigation led to difference in fuel pressure & injectors between 03 and 05. I replaced the tank, entire evap system, and injectors from the 03. At this point, all fuel, emissions, electronics, etc.. is 03. That's when it began the "start, no crank" condition.
The Saga continues but I think I found the culprit. I tested the crankshaft position sensor & camshaft position sensor with an oscilloscope. I saw a nice waveform from each, when cranking. I checked the ground and and all three injector drivers.

I pulled the fuel pump relay, pulled each connector off their injectors and poured a little bit of fresh fuel in the throttle body. Low and behold she coughed on first crank but 2nd, it fired and ran for 2 seconds. Plugged the fuel pump relay back in and pulled the line off the rail to get a sample of the fuel. Color was bright yellow and didn't quite have a powerful scent of fresh gasoline. The fuel I've been using is probably 5 months old, by now. You'd suspect it would have enough octane but perhaps where it was purchased had bad fuel to begin with.. Fingers crossed this is the culprit but looks like I'm dropping the tank and purging the lines & pump...
I'm embarrassed to say that it was the fuel.

Don’t be man, that happens. I would say, the “clear out every possible simple issue first” is a good rule.

I’ve had that frustrated laugh when it turns over, like hapoy, but dang it wasted a lot of time and made myself crazy.

Up and going is good! Ha.
  • Like
Reactions: macleanflood