Water pump lifespan

xXDavidCXx

TJ Enthusiast
Supporting Member
Joined
Jun 17, 2021
Messages
431
Location
AZ
I just replaced my mopar water pump 68382489AA with a gates replacement.

The pump lasted 13 months and 14k miles.

Is that normal?
 
  • Wow
Reactions: BlueC
Was it a true mopar? I bought what I thought was a mopar pump from wermopar.com in 2016. In 2021 after 60k miles it failed. Turns out there were no Chrysler/mopar indicators on the pump. I've since gone with a Gates. It has maybe 5,000 miles on it though.
 
Me too on the Gates pump, a few weeks ago it was like $23 on Amazon, time will tell.

easy install except for the broken bolt at the 12 o’clock position.
 
No, not normal. What’s the fluid look like?

I've had issues with metallic particles in the fluid. I spent weeks (years ago) flushing and replacing parts and I made some headway on getting rid of the particles. And yes, I flushed using prestone/thermocure and using the block hole too.
 
Last edited:
Was it a true mopar? I bought what I thought was a mopar pump from wermopar.com in 2016. In 2021 after 60k miles it failed. Turns out there were no Chrysler/mopar indicators on the pump. I've since gone with a Gates. It has maybe 5,000 miles on it though.

Old unit

IMG_3545.JPG
 
To be clear, it didn't fail or leak, but it was the source of squeaking under the hood that I wasn't going to live with, and it was getting worse.
 
I've had issues with metallic particles in the fluid. I spent weeks (years ago) flushing and replacing parts and I made some headway on getting rid of the particles. And yes, I flushed using prestone/thermocure and using the block hole too.

What’s the fluid look like today as far as “metal particles”?
 
Water pumps are one of those "you never know" situations. I always replace them when I get a new to me vehicle - the one time I didn't, it failed in fairly short order. I knew better, and it bit me in the ass. It was my TJ! I replaced it with a Gates.

I've seen them go 150K miles, or fail at under 1K - and everything in between. Just luck of the draw I guess. My old MBZ got a new pump with the engine rebuild at 298K. At 315K, the pump grenaded - I never saw anything like it. The bearing was completely gone, the fan was wobbling around, yet it didn't leak any coolant. I probably drove it 50 miles like that before I knew there was a problem!
 
My water pump went a couple weeks ago so I just went through a bunch of reading to decide on brand, didn’t wanna spend $300 on a Mopar.
Some guys have had no issues with Gates/Napa (made by Gates), some have had them go out prematurely which is why I steered away from Gates, even though it’s a reputable brand.
I’m gonna be replacing mine this weekend, I ended up deciding on an ACDelco, Made in US plus a metal impeller.
 
I installed a Gates almost exactly 3 years ago. IDK how many miles, but I drive it pretty regularly around town. Mine definitely had a metal impeller (since somebody else brought it up).