• Want to add an app icon for this forum to your mobile device's home screen? Check out this thread to see how.
  • Have an event you want to share? Check out the new forum event calendar and how-to use it in this thread here.
  • To both new members and existing members, please read this thread about posting your topics in the correct sub-forum. It makes my job (and my life) a lot easier!

LED tail light install issues

coloradomtn

New Member
Joined
Jun 23, 2018
Messages
9
Location
Colorado
Hi, I recently replaced my 03 taillights with LEDs. This is the product I installed.
Quadratec LED Tail Light Kit for 01-06 Jeep Wrangler TJ & Unlimited

During the installation, everything tested fine but I forgot to test the lights with the headlights on. When the headlights are turned on, the driver's side rear works fine but the passenger side doesn't. When the headlights are turned off, everything works perfectly. Any ideas on where I might have gotten the wiring wrong?
 
OP
coloradomtn

coloradomtn

New Member
Joined
Jun 23, 2018
Messages
9
Location
Colorado
Did you install the LED flasher relay to go with them?
Yes, we installed the flasher. The indicator and reverse lights on both sides work great. The only light that doesn't work is the passenger tail light when the headlights are turned on.
 

Chris

Administrator
Staff Member
Joined
Sep 28, 2015
Messages
39,700
Location
Salem, Oregon
Yes, we installed the flasher. The indicator and reverse lights on both sides work great. The only light that doesn't work is the passenger tail light when the headlights are turned on.
Sounds like a ground issue. The taillight circuit grounds to the body, so make sure the connections are clean where it mounts to the body.
 
  • Like
Reactions: K0LCB