P0301 not fixed after 1 month at dealership

Duckdawg1

New Member
Joined
Mar 14, 2019
Messages
7
Location
Northern Cali
I had the same problem with my 2000 4.0 tj and I did all the recommended fixes and ran myself in circles. It ended up being a bent push rod in the #1 cylinder. Can’t remeber which side . Easy to check.
 
  • Like
Reactions: KCsTJ

bromel

TJ Enthusiast
Joined
Oct 11, 2018
Messages
399
Location
Montauk, NY
Are you losing coolant? The cracked cylinder heads affected all 00 and 01s and some 02s. The first symptom is always unexplained loss of coolant.
 

Duckdawg1

New Member
Joined
Mar 14, 2019
Messages
7
Location
Northern Cali
Did you do a compression test? How was yours easy to check?
I did do a compression check and all were good with the exception of the #4 cylinder which was only a few pounds low. I finally pulled the valve cover and ran the engine. Noticed slop in the #1 rocker and it ended up being a bent push rod. Make sure you put something over your head to keep oil from spraying all over
 
  • Like
Reactions: Rusty Rivets

Rusty Rivets

Member
Joined
Mar 12, 2019
Messages
27
Location
West Tennessee
I did do a compression check and all were good with the exception of the #4 cylinder which was only a few pounds low. I finally pulled the valve cover and ran the engine. Noticed slop in the #1 rocker and it ended up being a bent push rod. Make sure you put something over your head to keep oil from spraying all over
Wow that definitely required you being attentive in order to hunt the problem down. I will keep all this in mind while troubleshooting. Thanks for the advice and sharing your situation. Any other advice?