TJ Fest 2021
Join us in Moab, Utah from 4/24/2021 to 5/1/2021 for the first annual TJ Fest 2021. Click here for more information.

The dreaded 06 PCM problem


OP
1Blacktj

1Blacktj

TJ Enthusiast
Joined
May 29, 2018
Messages
214
Location
Blowing Rock, NC, USA
Well Guys, i just got mine in from NAPA, it looks great externally, may have swapped the case and left my guts inside, IDK... But i do know that im still getting ERROR CODES: P0700, and P1604. Im to the point now where im about to check every individual pin and search for a pinout diagram.... This is agrivating.....
See in my situation I’ve never had a code thrown. So Napa sounds like it is a no. Let us know if anything else happens!
 
  • Like
Reactions: bustergaming

ncsusan08

New Member
Joined
Nov 14, 2018
Messages
7
Location
NC
For now, every few weeks or so when it starts messing up, I reset the PCM and it fixes it usually its a few months but sometimes it could be a few days. It is very strange to say the least
hi.....when you say you 'reset the PCM' how are you doing that? I've just started having this issue on my 06...I've changed every fluid, filter, temp sensor that have anything to do with this issue and i'm still getting the hesitation and then hard shift between 1st and 2nd....but only seems to happen when Rubi's not warmed up. (still testing this warmed up vs. taking off cold thing). I'm not getting any error codes/check engine lights either. so frustrating! thanks in advance! :)
 
OP
1Blacktj

1Blacktj

TJ Enthusiast
Joined
May 29, 2018
Messages
214
Location
Blowing Rock, NC, USA
hi.....when you say you 'reset the PCM' how are you doing that? I've just started having this issue on my 06...I've changed every fluid, filter, temp sensor that have anything to do with this issue and i'm still getting the hesitation and then hard shift between 1st and 2nd....but only seems to happen when Rubi's not warmed up. (still testing this warmed up vs. taking off cold thing). I'm not getting any error codes/check engine lights either. so frustrating! thanks in advance! :)
To reset the pcm you:
Disconnect negative battery terminal for 30 seconds
Reconnect jt
Get in the Jeep and turn the the ignition on without cutting the Jeep on
Turn on the lights and turn them back off.

This fix works anywhere from a few weeks to a few months. I’m in the cycle now that it hasn’t don’t it in about 2 months but once it does, I’ll just reset it again. Hope that helps!
 
  • Like
Reactions: miss80five

ncsusan08

New Member
Joined
Nov 14, 2018
Messages
7
Location
NC
hi.....when you say you 'reset the PCM' how are you doing that? I've just started having this issue on my 06...I've changed every fluid, filter, temp sensor that have anything to do with this issue and i'm still getting the hesitation and then hard shift between 1st and 2nd....but only seems to happen when Rubi's not warmed up. (still testing this warmed up vs. taking off cold thing). I'm not getting any error codes/check engine lights either. so frustrating! thanks in advance! :)

is this the reset? I've also heard holding the brakes for 30sec while battery unhooked as well.
Disconnect positive battery cable.
Ground positive cable for 30 seconds.
Reconnect positive cable
Turn ignition key to the "run" position (do not start engine)
Turn headlights on.
Turn headlights off.
Turn ignition off.
Computer is now reset.
 
  • Like
Reactions: miss80five

ncsusan08

New Member
Joined
Nov 14, 2018
Messages
7
Location
NC
To reset the pcm you:
Disconnect negative battery terminal for 30 seconds
Reconnect jt
Get in the Jeep and turn the the ignition on without cutting the Jeep on
Turn on the lights and turn them back off.

This fix works anywhere from a few weeks to a few months. I’m in the cycle now that it hasn’t don’t it in about 2 months but once it does, I’ll just reset it again. Hope that helps!
I knew a NC Jeeper would be helpful, thank you! hell, all real Jeepers are helpful! Thanks, gang! headed out in the cold rain to test this out! :)
 

miss80five

New Member
Joined
Jan 29, 2019
Messages
19
Location
NJ
ARRRGH, having this problem now with my manual LJ. Problem is, I could live with it if it weren't for it not passing inspection because of this. Replaced two O2 sensors (needed to be replaced), but it won't complete I/M monitors or keep the flash in order to pass inspection in NJ. I've looked into replacing from a dealer ($1300 and $916) and sending it to G7 computers in NY to be repaired, although they can't guarantee repair and sending to them is $225 (they state refund if unable to repair). So, still driving illegally in NJ until this can be resolved.
 
OP
1Blacktj

1Blacktj

TJ Enthusiast
Joined
May 29, 2018
Messages
214
Location
Blowing Rock, NC, USA
ARRRGH, having this problem now with my manual LJ. Problem is, I could live with it if it weren't for it not passing inspection because of this. Replaced two O2 sensors (needed to be replaced), but it won't complete I/M monitors or keep the flash in order to pass inspection in NJ. I've looked into replacing from a dealer ($1300 and $916) and sending it to G7 computers in NY to be repaired, although they can't guarantee repair and sending to them is $225 (they state refund if unable to repair). So, still driving illegally in NJ until this can be resolved.
See in my case it doesn’t throw any codes at all. I don’t wanna jinx myself but I havnt had the issue for a few months now but I didn’t do anything to actually fix it so that’s always good but seriously Chrysler should have put out a recall for this years ago!
 

miss80five

New Member
Joined
Jan 29, 2019
Messages
19
Location
NJ
Ah, but that's exactly the issue I'm having. Since the PCM is not working, it can't go through drive cycles. It can't go through drive cycles because the I/M monitors won't complete them. Because they won't complete them, they can't check if there are any codes to throw. I'd reflashed it twice (just putting the VIN program on it - not updates), long enough to go through a couple drive cycles and throw the codes. Unfortunately, since the PCM is messed up, it won't hold the flash, but I take a picture of the scan tool with the codes to fix them. This doesn't fix the PCM problem, but it at least gets me to fix other issues going on besides it. You won't get any codes about the PCM issue, since its the hub of finding mechanical issues with the Jeep, not computer issues with itself. Regardless, it won't pass NJ (emissions) inspection if it can't go through the I/M monitors and complete the drive cycles.
 

MountaineerTom

LJ Enthusiast, Retired USAF Weapons Loader
Supporting Member
Joined
Sep 25, 2018
Messages
2,431
Location
South Carolina
Regarding the hard 1-2 shift with automatics, I had that happen a few times with my ‘06 not long after I putchased it. I tried the resetting but it came back. In the summer of 2017, I installed a B&M transmission cooler. I’ve not had a hard shift since. Maybe it’s just coincidence, I dont know.
 
  • Like
Reactions: Shatto

Shatto

TJ Enthusiast
Joined
Jun 28, 2018
Messages
245
Location
Apache Junction, Arizona
Regarding the hard 1-2 shift with automatics, I had that happen a few times with my ‘06 not long after I putchased it. I tried the resetting but it came back. In the summer of 2017, I installed a B&M transmission cooler. I’ve not had a hard shift since. Maybe it’s just coincidence, I dont know.
I've had bad shifting cured by a flush and adding Amsoil ATF.
 
  • Like
Reactions: MountaineerTom

MountaineerTom

LJ Enthusiast, Retired USAF Weapons Loader
Supporting Member
Joined
Sep 25, 2018
Messages
2,431
Location
South Carolina
I should have added, about 3 months earlier I did a fluid and filter change as well. ATF +4
 

skrelnik

TJ Addict
Supporting Member
Joined
Jan 10, 2018
Messages
1,907
Location
CT, United States
ARRRGH, having this problem now with my manual LJ. Problem is, I could live with it if it weren't for it not passing inspection because of this. Replaced two O2 sensors (needed to be replaced), but it won't complete I/M monitors or keep the flash in order to pass inspection in NJ. I've looked into replacing from a dealer ($1300 and $916) and sending it to G7 computers in NY to be repaired, although they can't guarantee repair and sending to them is $225 (they state refund if unable to repair). So, still driving illegally in NJ until this can be resolved.
What codes are you throwing?

I also have a manual LJ with a wonky PCM issue. Every summer all four O2 sensor codes come on. My local emissions test center said it is the PCM and I should time my emissions appointment around when the Jeep has no codes.

So you can disconnect your battery to reset the codes, then drive for 200 miles, and if all good head over to the emissions test center. If not, then you must repeat. One time I had to pay a fine because I was late to get my emissions testing done, I failed two times before I was able to pass.
 
  • Like
Reactions: miss80five

Curteze

New Member
Joined
May 4, 2018
Messages
11
Location
Louisiana, USA
I still am throwing codes even after the rebuild, and the condition is still the same. i reset every other fill up. P1604, p0700, p0613 are what im getting. The on is a transmission code that takes the special tool to read. Scared to bring it to the deal and let them read. Im still rolling, 109000 miles on it.
Thinking about trading it in, just dont know what the car lot would say about the codes.
 

miss80five

New Member
Joined
Jan 29, 2019
Messages
19
Location
NJ
What codes are you throwing?

I also have a manual LJ with a wonky PCM issue. Every summer all four O2 sensor codes come on. My local emissions test center said it is the PCM and I should time my emissions appointment around when the Jeep has no codes.

So you can disconnect your battery to reset the codes, then drive for 200 miles, and if all good head over to the emissions test center. If not, then you must repeat. One time I had to pay a fine because I was late to get my emissions testing done, I failed two times before I was able to pass.
It won't throw any codes as long as the PCM is messed up. When I reflash, I get a couple of days to drive the 80 miles (through a drive cycle) to get any codes to come up and I need to take a pic of it before it drops the flash. I'm looking at Flagship One for a new PCM with a lifetime warranty, since this is apparently a very common issue and repeated occurence.